Wednesday, August 12, 2009

Usare Firefox 3.5 stabile su Ubuntu Jaunty Jackalope (9.04) [HowTo]

Salve ragazzi! Poiché non ho avuto altre occasioni per farlo, vi auguro innanzitutto BUONE VACANZE a tutti voi ;)

Detto ciò, torniamo alle cose importanti. Da poco tempo è disponibile su Ubuntu Karmic Koala (la nuova versione in sviluppo del nostro sistema operativo preferito (o, perlomeno, del mio sistema operativo preferito :P ) Firefox 3.5 stabile, la nuova versione del miglior browser web per definizione (per ora (Google Chrome, CBCR)).

Il logo di Firefox 3.5
Il logo di Firefox 3.5

Friday, February 27, 2009

Bespin: Strike back the Empire! [KDE]

Salve amici! Prima di andare a studiare (come ogni santo giorno ormai -_-' ) vi propongo questo bel tema per KDE4:

Il tema Bespin
Il tema Bespin

Thursday, January 22, 2009

[Python] CheckRepo

A volte ritornano, diceva qualcuno... Ed eccomi qua, infatti! Scusate l'assenza ma ho qualche problema a casa e all'università... Appena potrò stare un po' tranquillo tornerò quì a postarvi cose carine ;)

Allora, qual è il piatto del giorno oggi? Un simpatico script python che uso da un pò di tempo, e che magari può risultare utile a qualcunodi voi che, come me, usa le versioni instabili dei vari sistemi operativi GNU\Linux-based (come ad esempio Ubuntu, per dirne una...). Qual è il problema, dunque? È che sto usando dal primo giorno Ubuntu Jaunty Jackalope, e in più mi piace usare miliardi di repository di terze parti perché sono fissato con la roba buggosa... Cosa succede però passando ad esempio da Intrepid a Jaunty? Che tutti i repository che si usavano con Intrepid, molto probabilmente non hanno ancora aperto la loro brava sezione per Jaunty, e quindi ci si ritrova (paradossalmente, ma a volte succede (mi viene un esempio: mi è successo esattamente così con Gnome-DO ai bei tempi gnomisti al passaggio Hardy -> Intrepid)) addirittura con software meno aggiornato di quello che si può avere con la versione di s.o. precedente!

Ecco quindi che entra in gioco il mio script: quello che fa è semplicemente controllare che esistano nuove versioni dei vari repository che usate, al più aggiornati alla vostra attuale brava versione di Ubuntu :) Implicitamente ho quindi ammesso che per ora funziona solo per Ubuntu, ma se qualcuno può darmi piccole informazioni sul funzionamento dei vari repository diversi da quelli deb, o magari anche sui repository di debian, etc, potrei sempre migliorare lo script.

Per giocare col mio bravo script serve solamente scaricare il file python che vi linko quì: CheckRepo.
Spostatelo ad esempio nella vostra cartella Documenti, rendetelo eseguibile e create un link simbolico:
mv check.py ~/Documenti
cd ~/Documenti
chmod +x check.py
cd /usr/local/bin
sudo ln -s ~/Documenti/check.py checkrepo
o improvvisate, visto che se vi serve questo script molto probabilmente siete già esperti in questi magheggi terminaleschi ;-) Seguendo questi comandi potrete tranquillamente richiamare il mio/vostro bravo scriptino da terminale, lanciando semplicemente checkrepo. Sperando di esservi stato utile, vi saluto.

Alla prossima!

R

Friday, December 5, 2008

KDE 4.2: What's new

Hi guys, after writing about KDE 4 in Italian, I'd like to share with worldwide friends what's new in the next KDE 4 release.

Manca poco alla rivoluzione! [KDE 4.2]



Tuesday, November 11, 2008

[consigli] Progetto Eulero

Ciao! Sei un programmatore? Ti piacciono le sfide informatiche? Sei un folle che trova piacere a distruggere il proprio cervello su cose poco inerenti agli esami che hai la prossima settimana? Bene, allora sei me 8O e allora voglio consigliarti, se ancora non lo conosci, il sito projecteuler.net

il logo di Progetto Eulero
il logo di Progetto Eulero
avviso però che il sito propone problemi strani da risolvere, è tutto in inglese ( :( ) e bisogna registrarsi, comunque magari provo a scrivere la traduzione dei problemi più tardi... Ora scappo all'uni!

Ciao! ;-)

EDIT: Fatto! Controllate la pagina Progetto Eulero :-)

[RESOLVED] Problemi scheda wireless intel 3945 e nuove versioni del kernel Linux

Se anche voi, come me, avete un modulo wireless Intel 3945, e aggiornando ad una versione >= 2.6.27-7.6 del kernel Linux siete stati accolti gentilmente da un wireless morto,

La vostra faccia quando vi siete accorti che era morto il wireless
La vostra faccia quando vi siete accorti che era morto il wireless
allora il problema è facilmente risolvibile (si spera).